Plesk 10 Unable to activate the domain: The domain is suspended

Unable to activate the domain: The domain is suspended. Some of the selected domains or aliases were not activated.

I had one domain of many that was disabled after upgrade to 10.4.4

FIX:

yum install tomcat* psa-mod_jk -y
/usr/local/psa/admin/bin/tomcatmng --stop
/usr/local/psa/admin/bin/tomcatmng --install-psa
/usr/local/psa/bin/domain -u YOUR.SUSPENDED.DOMAIN -status enabled

 

Job done

 

 

Adding original error message:

[root@srv2 ~]# /usr/local/psa/bin/domain -u YOUR.SUSPENDED.DOMAIN -status enabled
PleskUtilException: ‘/usr/local/psa/admin/bin/tomcatmng’ ‘–install-vhost’ ‘–vhost-name=YOUR.SUSPENDED.DOMAIN’ ‘–alias=YOUR.SUSPENDED.DOMAIN’ failed with code .

stdout:
tomcatmng: Document /usr/share/tomcat5/conf/server.xml not contain service PSA tag

stderr:
tomcatmng: Document /usr/share/tomcat5/conf/server.xml not contain service PSA tag

file: /usr/local/psa/admin/plib/Service/Agent/Transport/Local/Exec.php
line: 71
code: 0
trace: #0 /usr/local/psa/admin/plib/Service/Agent/Transport/Local.php(58): Service_Agent_Transport_Local_Exec->process(0, Object(Service_Agent_Command_Exec), Object(Service_Agent_Log), Object(Service_Agent_Transport_LocalTransaction))
#1 /usr/local/psa/admin/plib/Service/Agent/Transport/Local.php(24): Service_Agent_Transport_Local->_command(0, Object(Service_Agent_Command_Exec), Object(Service_Agent_Transport_LocalTransaction), Object(Service_Agent_Log))
#2 /usr/local/psa/admin/plib/Service/Agent.php(133): Service_Agent_Transport_Local->process(‘1cf9764beadf5f0…’, Array, Object(Service_Agent_Log))
#3 /usr/local/psa/admin/plib/Service/AbstractMng.php(32): Service_Agent->commit()
#4 /usr/local/psa/admin/plib/Service/AbstractMng.php(26): Service_AbstractMng->commit()
#5 /usr/local/psa/admin/plib/Service/TomcatMng.php(166): Service_AbstractMng->_exec(‘tomcatmng’, Array, NULL, NULL)
#6 /usr/local/psa/admin/plib/Service/TomcatMng.php(72): Service_TomcatMng->_exec(‘install-vhost’, Array)
#7 /usr/local/psa/admin/plib/class.DSTomcat.php(120): Service_TomcatMng->install_vhost(‘YOUR.SUSPENDED.DOMAIN….’, ‘YOUR.SUSPENDED.DOMAIN…’)
#8 /usr/local/psa/admin/plib/Domain.php(1929): DSTomcat->turnOn()
#9 /usr/local/psa/admin/plib/Domain.php(1995): Domain->_setTomcatStatus(0)
#10 /usr/local/psa/admin/plib/Domain.php(201): Domain->_setServicesStatus(0)
#11 /usr/local/psa/admin/plib/Domain.php(133): Domain->turnOnUnix(‘4’, 0)
#12 /usr/local/psa/admin/plib/BsDomain.php(812): Domain->turnOn(260)
#13 /usr/local/psa/admin/plib/api-common/AbstractCuDomain.php(154): BsDomain->turnOn(‘4’)
#14 /usr/local/psa/admin/plib/api-common/cuDomain.php(1926): AbstractCuDomain->changeStatus(Object(BsDomain), 0)
#15 /usr/local/psa/admin/plib/api-common/cuDomain.php(156): cuDomain->cmdUpdate(‘YOUR.SUSPENDED.DOMAIN….’)
#16 /usr/local/psa/admin/plib/api-common/cuDomain.php(105): cuDomain->_processDomainNameCmd(‘update’, ‘YOUR.SUSPENDED.DOMAIN….’)
#17 /usr/local/psa/admin/plib/api-common/AbstractCuExecutor.php(21): cuDomain->__construct()
#18 /usr/local/psa/admin/plib/api-common/CuExecutor.php(29): AbstractCuExecutor->_execUtil(‘cuDomain’, NULL)
#19 /usr/local/psa/admin/plib/api-cli/CliUtilityRunner.php(18): CuExecutor->run()
#20 /usr/local/psa/admin/plib/api-cli/CliUtilityRunner.php(43): CliUtilityRunner->run()
#21 /usr/local/psa/admin/plib/api-cli/domain.php(4): require_once(‘/usr/local/psa/…’)
#22 {main}

An error occurred during domain update: Turn on domain failed: tomcatmng: Document /usr/share/tomcat5/conf/server.xml not contain service PSA tag